<!doctype html>
<html data-n-head-ssr dir="ltr" lang="vi" data-n-head="%7B%22dir%22:%7B%22ssr%22:%22ltr%22%7D,%22lang%22:%7B%22ssr%22:%22vi%22%7D%7D">
  <head >
    <title>Tạo mô hình tham số URL APIRequestName trong | AppMaster docs</title><meta data-n-head="ssr" lang="en"><meta data-n-head="ssr" charset="utf-8"><meta data-n-head="ssr" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="ssr" name="format-detection" content="telephone=no"><meta data-n-head="ssr" name="application-name" content="AppMaster - ultimate all-in no-code platform"><meta data-n-head="ssr" name="msapplication-TileColor" content="#1890FF"><meta data-n-head="ssr" name="msapplication-TileImage" content="/mstile-144x144.png"><meta data-n-head="ssr" name="msapplication-square70x70logo" content="/mstile-70x70.png"><meta data-n-head="ssr" name="msapplication-square150x150logo" content="/mstile-150x150.png"><meta data-n-head="ssr" name="msapplication-wide310x150logo" content="/mstile-310x150.png"><meta data-n-head="ssr" name="msapplication-square310x310logo" content="/mstile-310x310.png"><meta data-n-head="ssr" data-hid="og:title" property="og:title" content="Tạo mô hình tham số URL APIRequestName trong | AppMaster docs"><meta data-n-head="ssr" data-hid="twitter:title" property="twitter:title" content="Tạo mô hình tham số URL APIRequestName trong | AppMaster docs"><meta data-n-head="ssr" data-hid="og:description" property="og:description" content="Trả về một đối tượng mô hình Tham số URL mới cho một yêu cầu API cụ thể từ các trường đã cho. | AppMaster docs"><meta data-n-head="ssr" data-hid="twitter:description" property="twitter:description" content="Trả về một đối tượng mô hình Tham số URL mới cho một yêu cầu API cụ thể từ các trường đã cho. | AppMaster docs"><meta data-n-head="ssr" data-hid="description" name="description" content="Trả về một đối tượng mô hình Tham số URL mới cho một yêu cầu API cụ thể từ các trường đã cho. | AppMaster docs"><meta data-n-head="ssr" data-hid="og:url" property="og:url" content="https://appmaster.io/vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong"><meta data-n-head="ssr" data-hid="twitter:url" property="twitter:url" content="https://appmaster.io/vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong"><meta data-n-head="ssr" data-hid="og:image" property="og:image" content="https://appmaster.io/images/appmaster.png"><meta data-n-head="ssr" data-hid="twitter:image" property="twitter:image" content="https://appmaster.io/images/appmaster.png"><meta data-n-head="ssr" data-hid="og:type" property="og:type" content="website"><meta data-n-head="ssr" data-hid="twitter:card" property="twitter:card" content="summary_large_image"><meta data-n-head="ssr" data-hid="twitter:site" property="twitter:site" content="@appmaster_io"><meta data-n-head="ssr" data-hid="twitter:creator" property="twitter:creator" content="@appmaster_io"><meta data-n-head="ssr" data-hid="twitter:domain" property="twitter:domain" content="https://appmaster.io"><meta data-n-head="ssr" data-hid="fb:app_id" property="fb:app_id" content="3544053912331320"><base href="/docs/"><link data-n-head="ssr" rel="icon" type="image/x-icon" href="/favicon.ico"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="57x57" href="/apple-touch-icon-57x57.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="114x114" href="/apple-touch-icon-114x114.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="72x72" href="/apple-touch-icon-72x72.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="144x144" href="/apple-touch-icon-144x144.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="60x60" href="/apple-touch-icon-60x60.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="120x120" href="/apple-touch-icon-120x120.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="76x76" href="/apple-touch-icon-76x76.png"><link data-n-head="ssr" rel="apple-touch-icon-precomposed" sizes="152x152" href="/apple-touch-icon-152x152.png"><link data-n-head="ssr" rel="icon" type="image/png" href="/favicon-196x196.png" sizes="196x196"><link data-n-head="ssr" rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96"><link data-n-head="ssr" rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32"><link data-n-head="ssr" rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16"><link data-n-head="ssr" rel="icon" type="image/png" href="/favicon-128.png" sizes="128x128"><link data-n-head="ssr" rel="preload" href="/fonts/UcC73FwrK3iLTeHuS_fvQtMwCp50KnMa1ZL7.woff2" type="font/woff2" crossorigin="anonymous" as="font"><link data-n-head="ssr" rel="preload" href="/fonts/UcC73FwrK3iLTeHuS_fvQtMwCp50KnMa0ZL7SUc.woff2" type="font/woff2" crossorigin="anonymous" as="font"><link data-n-head="ssr" rel="alternate" hreflang="en" href="https://appmaster.io/docs/tao-mo-hinh-tham-so-url-apirequestname-trong/make-apirequestname-url-params-model-in"><link data-n-head="ssr" rel="alternate" hreflang="pt" href="https://appmaster.io/docs/pt/tao-mo-hinh-tham-so-url-apirequestname-trong/fazer-um-modelo-de-params-apirequestname-url-em"><link data-n-head="ssr" rel="alternate" hreflang="zh" href="https://appmaster.io/docs/zh/tao-mo-hinh-tham-so-url-apirequestname-trong/shi-apirequestname-url-paramsmo-xing-zai"><link data-n-head="ssr" rel="alternate" hreflang="ru" href="https://appmaster.io/docs/ru/tao-mo-hinh-tham-so-url-apirequestname-trong/sdelat-apirequestname-url-params-model-iu-v"><link data-n-head="ssr" rel="alternate" hreflang="ar" href="https://appmaster.io/docs/ar/tao-mo-hinh-tham-so-url-apirequestname-trong/j-l-nmwdhj-apirequestname-url-fy"><link data-n-head="ssr" rel="alternate" hreflang="ja-JP" href="https://appmaster.io/docs/ja/tao-mo-hinh-tham-so-url-apirequestname-trong/de-apirequestname-url-params-model-wozuo-cheng-shimasu"><link data-n-head="ssr" rel="alternate" hreflang="fr" href="https://appmaster.io/docs/fr/tao-mo-hinh-tham-so-url-apirequestname-trong/rendre-le-modele-apirequestname-url-params-en"><link data-n-head="ssr" rel="alternate" hreflang="de" href="https://appmaster.io/docs/de/tao-mo-hinh-tham-so-url-apirequestname-trong/machen-apirequestname-url-params-model-in"><link data-n-head="ssr" rel="alternate" hreflang="es" href="https://appmaster.io/docs/es/tao-mo-hinh-tham-so-url-apirequestname-trong/hacer-apirequestname-url-params-modelo-en"><link data-n-head="ssr" rel="alternate" hreflang="tr-TR" href="https://appmaster.io/docs/tr/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-params-modelini-yap"><link data-n-head="ssr" rel="alternate" hreflang="id-ID" href="https://appmaster.io/docs/id/tao-mo-hinh-tham-so-url-apirequestname-trong/buat-model-params-url-apirequestname-di"><link data-n-head="ssr" rel="alternate" hreflang="bn-BD" href="https://appmaster.io/docs/bn/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-params-mddel-krun"><link data-n-head="ssr" rel="alternate" hreflang="hi-IN" href="https://appmaster.io/docs/hi/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-params-monddl-bnaaen"><link data-n-head="ssr" rel="alternate" hreflang="ko-KR" href="https://appmaster.io/docs/ko/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-maegaebyeonsu-model-mandeulgi"><link data-n-head="ssr" rel="alternate" hreflang="nl" href="https://appmaster.io/docs/nl/tao-mo-hinh-tham-so-url-apirequestname-trong/maak-apirequestname-url-params-model-in"><link data-n-head="ssr" rel="alternate" hreflang="it-IT" href="https://appmaster.io/docs/it/tao-mo-hinh-tham-so-url-apirequestname-trong/rendere-il-modello-apirequestname-url-params-in"><link data-n-head="ssr" rel="alternate" hreflang="pl-PL" href="https://appmaster.io/docs/pl/tao-mo-hinh-tham-so-url-apirequestname-trong/make-apirequestname-url-params-model-in-1"><link data-n-head="ssr" rel="alternate" hreflang="th-TH" href="https://appmaster.io/docs/th/tao-mo-hinh-tham-so-url-apirequestname-trong/sraangomedl-apirequestname-url-params-ain"><link data-n-head="ssr" rel="alternate" hreflang="vi-VN" href="https://appmaster.io/docs/vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong"><link data-n-head="ssr" rel="alternate" hreflang="x-default" href="https://appmaster.io/docs/tao-mo-hinh-tham-so-url-apirequestname-trong/make-apirequestname-url-params-model-in"><link data-n-head="ssr" rel="canonical" href="https://appmaster.io/docs/vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong"><script data-n-head="ssr" type="application/ld+json">{"@context":"https://schema.org","@type":"Article","headline":"Tạo mô hình tham số URL APIRequestName trong","url":"https://appmaster.io/vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong","description":"Trả về một đối tượng mô hình Tham số URL mới cho một yêu cầu API cụ thể từ các trường đã cho.","articleBody":"Kết nối dòng chảy[Input] In - bắt đầu thực thi khối. [Output] Out - kích hoạt khi khối thực hiện xong. Kết nối dữ liệu[Input] Fields (multiple, any) - các trường của mô hình Thông số URL (được xác định trong phần tương ứng của nó trong Yêu cầu API bên ngoài). [Output] Model (model ) - mô hình kết quả."}</script><link rel="preload" href="/docs/_nuxt/7e01a59.js" as="script"><link rel="preload" href="/docs/_nuxt/3458d2d.js" as="script"><link rel="preload" href="/docs/_nuxt/385e0b7.js" as="script"><link rel="preload" href="/docs/_nuxt/705d46d.js" as="script"><link rel="preload" href="/docs/_nuxt/3953717.js" as="script"><link rel="preload" href="/docs/_nuxt/0636c76.js" as="script"><link rel="preload" href="/docs/_nuxt/5c018ca.js" as="script"><link rel="preload" href="/docs/_nuxt/f389214.js" as="script"><link rel="preload" href="/docs/_nuxt/cb7eb6e.js" as="script"><link rel="preload" href="/docs/_nuxt/b52fb0f.js" as="script"><link rel="preload" href="/docs/_nuxt/fe1d34d.js" as="script"><link rel="preload" href="/docs/_nuxt/0349aee.js" as="script"><link rel="preload" href="/docs/_nuxt/71dc126.js" as="script"><link rel="preload" href="/docs/_nuxt/306525a.js" as="script"><style data-vue-ssr-id="382a115c:0 5959e63c:0 4c9cd9de:0 43955072:0 788ba835:0 c625722c:0 eabc81d8:0 1b9489d9:0 05e9c030:0 20c27100:0 1714ae82:0 18098bfc:0 5367ec79:0 a55fd540:0">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</style>
  </head>
  <body class="pt-12 sm:pt-16 body-offset" data-n-head="%7B%22class%22:%7B%22ssr%22:%22pt-12%20sm:pt-16%20body-offset%22%7D%7D">
    <div data-server-rendered="true" id="__nuxt"><!----><div id="__layout"><div class="site-container test"><header class="header fixed top-0 min-h-[48px] left-0 w-full bg-dark-500 z-10 py-2 sm:py-4" data-v-4cb8c587><div class="container mx-auto xl:max-w-none" data-v-4cb8c587><div class="header-content flex items-center justify-between" data-v-4cb8c587><div class="header-left flex-1 gap-2 sm:gap-4 items-center inline-flex lg:w-[240px] lg:flex-none" data-v-4cb8c587><button class="header-btn w-8 h-8 sm:w-9 sm:h-9 p-1.5 cursor-pointer relative lg:hidden" data-v-4cb8c587><span class="absolute top-[9px] sm:top-2 left-0 right-0 w-5 sm:w-6 h-[1.67px] mx-auto bg-white rounded-sm" data-v-4cb8c587></span> <span class="absolute top-[15px] sm:top-4 left-0 right-0 w-5 sm:w-6 h-[1.67px] mx-auto bg-white rounded-sm" data-v-4cb8c587></span> <span class="absolute top-[21px] sm:top-6 left-0 right-0 w-5 sm:w-6 h-[1.67px] mx-auto bg-white rounded-sm" data-v-4cb8c587></span></button> <a href="/" data-v-4cb8c587><img width="140" height="24" src="/docs/_nuxt/img/logo.f9e7cb5.svg" alt="logo" class="header-logo sm:w-[140px]" data-v-4cb8c587></a> <a href="/docs/vi" class="header-logo__content inline-flex items-center gap-2 nuxt-link-active" data-v-4cb8c587><span class="bg-primary-500 px-1.5 rounded text-white text-[10px] leading-5 font-semibold sm:text-xs sm:leading-5" data-v-4cb8c587>
            DOCS
          </span></a></div> <div class="header-right inline-flex gap-8 items-center lg:justify-between lg:flex-1 lg:pl-1.5 2xl:pl-8 3xl:pl-10" data-v-4cb8c587><div class="menu-widget lg:pl-9 xl:pl-0" data-v-4cb8c587></div> <div class="header-controls inline-flex gap-8 lg:gap-6 items-center 2xl:flex-1 2xl:max-w-[482px] 3xl:max-w-[507px]" data-v-4cb8c587><div class="2xl:flex-1" data-v-4cb8c587><form class="header-form hidden sm:block w-[200px] relative lg:mr-7 xl:mr-0 3xl:w-[220px]" data-v-4cb8c587><span class="header-form__btn absolute top-[11px] left-3" data-v-4cb8c587><svg class="svg w-3.7 h-3.7 text-other-1000" data-v-4cb8c587><use xlink:href="/images/icons.svg#search-ico" data-v-4cb8c587></use></svg></span> <input type="text" placeholder="Tìm kiếm" class="header-form-input pl-8 pr-[65px] font-normal text-sm leading-6" data-v-4cb8c587> <div class="form-icons inline-flex items-center gap-1 absolute right-1.5 top-0 bottom-0 m-auto" data-v-4cb8c587><i class="w-6 h-6 border border-solid border-dark-300 inline-flex items-center justify-center rounded" data-v-4cb8c587><svg class="svg w-3.7 h-3.7 text-dark-300" data-v-4cb8c587><use xlink:href="/images/icons.svg#command-ico" data-v-4cb8c587></use></svg></i> <i class="w-6 h-6 border border-solid border-dark-300 inline-flex items-center justify-center rounded" data-v-4cb8c587><svg class="svg w-2.5 h-3.7 text-dark-300" data-v-4cb8c587><use xlink:href="/images/icons.svg#k-ico" data-v-4cb8c587></use></svg></i></div></form></div> <div class="lang resize-none relative z-20 sm:inline-block" data-v-6ec72199 data-v-4cb8c587><div class="lang__header cursor-pointer" data-v-6ec72199><img width="24" height="24" src="/images/icons/vi-flag.svg" alt="us-flag" class="lang__ico" data-v-6ec72199></div> <div class="lang__content absolute w-[394px] right-0" data-v-6ec72199><div class="lang-items bg-white justify-between overflow-hidden flex flex-wrap items-start p-3 rounded-xl" data-v-6ec72199><a href="/docs/tao-mo-hinh-tham-so-url-apirequestname-trong/make-apirequestname-url-params-model-in" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/us-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            English
          </span></span></a><a href="/docs/fr/tao-mo-hinh-tham-so-url-apirequestname-trong/rendre-le-modele-apirequestname-url-params-en" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/fr-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Français
          </span></span></a><a href="/docs/es/tao-mo-hinh-tham-so-url-apirequestname-trong/hacer-apirequestname-url-params-modelo-en" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/es-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Español
          </span></span></a><a href="/docs/de/tao-mo-hinh-tham-so-url-apirequestname-trong/machen-apirequestname-url-params-model-in" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/de-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Deutsch
          </span></span></a><a href="/docs/ru/tao-mo-hinh-tham-so-url-apirequestname-trong/sdelat-apirequestname-url-params-model-iu-v" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/ru-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Русский
          </span></span></a><a href="/docs/ja/tao-mo-hinh-tham-so-url-apirequestname-trong/de-apirequestname-url-params-model-wozuo-cheng-shimasu" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/ja-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            日本語
          </span></span></a><a href="/docs/ko/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-maegaebyeonsu-model-mandeulgi" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/ko-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            한국어
          </span></span></a><a href="/docs/zh/tao-mo-hinh-tham-so-url-apirequestname-trong/shi-apirequestname-url-paramsmo-xing-zai" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/zh-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            简体中文
          </span></span></a><a href="/docs/pt/tao-mo-hinh-tham-so-url-apirequestname-trong/fazer-um-modelo-de-params-apirequestname-url-em" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/pt-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Português
          </span></span></a><a href="/docs/hi/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-params-monddl-bnaaen" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/hi-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            हिन्दी
          </span></span></a><a href="/docs/bn/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-params-mddel-krun" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/bn-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            বাংলা
          </span></span></a><a href="/docs/ar/tao-mo-hinh-tham-so-url-apirequestname-trong/j-l-nmwdhj-apirequestname-url-fy" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/uae-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            العربية
          </span></span></a><a href="/docs/id/tao-mo-hinh-tham-so-url-apirequestname-trong/buat-model-params-url-apirequestname-di" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/id-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Bahasa Indonesia
          </span></span></a><a href="/docs/tr/tao-mo-hinh-tham-so-url-apirequestname-trong/apirequestname-url-params-modelini-yap" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/tr-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Türkçe
          </span></span></a><a href="/docs/it/tao-mo-hinh-tham-so-url-apirequestname-trong/rendere-il-modello-apirequestname-url-params-in" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/it-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Italiano
          </span></span></a><a href="/docs/pl/tao-mo-hinh-tham-so-url-apirequestname-trong/make-apirequestname-url-params-model-in-1" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/pl-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Polski
          </span></span></a><a href="/docs/vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong" aria-current="page" class="inline-block w-[165px] rounded-lg nuxt-link-exact-active nuxt-link-active" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5 active" data-v-6ec72199><img width="20" height="20" src="/images/icons/vi-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Tiếng Việt
          </span></span></a><a href="/docs/nl/tao-mo-hinh-tham-so-url-apirequestname-trong/maak-apirequestname-url-params-model-in" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/nl-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            Nederlands
          </span></span></a><a href="/docs/th/tao-mo-hinh-tham-so-url-apirequestname-trong/sraangomedl-apirequestname-url-params-ain" class="inline-block w-[165px] rounded-lg" data-v-6ec72199><span class="lang-item flex items-center py-2 px-3 current hover:bg-other-300 rounded-lg gap-2.5" data-v-6ec72199><img width="20" height="20" src="/images/icons/th-flag.svg" alt="us flag" class="lang__ico lang-item__ico w-5 h-5" data-v-6ec72199> <span class="lang-item__title inline-block text-micro leading-5 font-semibold text-dark-500" data-v-6ec72199>
            ภาษาไทย
          </span></span></a></div></div></div> <button class="btn header__btn py-1.5 px-[15px] rounded-md border border-solid btn-blue border-primary-500 bg-primary-500 text-white mr-6 hidden lg:inline-flex lg:mr-0 lg:px-4 lg:py-[7px] 2xl:text-micro 2xl:leading-5" data-v-4cb8c587><span class="btn__title inline-block text-micro font-semibold leading-5" data-v-4cb8c587>
              Bắt đầu
            </span></button></div></div></div></div> <div class="mobile-menu fixed top-0 left-0 w-full flex z-20" data-v-01a2f9b6 data-v-4cb8c587><div class="mobile-content h-full w-[280px] bg-white px-2" data-v-01a2f9b6><div class="mobile-header flex items-center justify-between px-2 py-4" data-v-01a2f9b6><a href="/" class="mobile-logo inline-flex items-center gap-2" data-v-01a2f9b6><img width="135" height="20" src="/docs/_nuxt/img/logo-dark.de9b0ce.svg" alt="logo" data-v-01a2f9b6> <span class="bg-primary-500 px-1.5 rounded text-white text-[10px] leading-5 font-semibold sm:text-xs sm:leading-5" data-v-01a2f9b6>
          DOCS
        </span></a> <button class="close-mobile w-8 h-8 text-blueGray-600 inline-flex items-center justify-center" data-v-01a2f9b6><svg class="svg max-w-full max-h-full w-3 h-3" data-v-01a2f9b6><use xlink:href="/images/icons.svg#close-ico" data-v-01a2f9b6></use></svg></button></div> <div class="mobile-area" data-v-01a2f9b6><div class="mobile-btn py-2" data-v-01a2f9b6><a href="https://studio.appmaster.io/auth/signup" rel="nofollow noopener" class="bg-primary-500 w-full py-2 rounded-md inline-flex text-white text-micro leading-5 font-semibold justify-center" data-v-01a2f9b6>
          Bắt đầu
        </a></div> <div class="header-select pt-2 pb-4" data-v-01a2f9b6></div> <div class="nav-items pb-20" data-v-01a2f9b6><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Bắt đầu
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/appmaster-io-la-gi" class="nav-item-title flex-1" data-v-01a2f9b6>
                  AppMaster.io là gì
                </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Bắt đầu
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/kien-truc-ung-dung" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Kiến trúc ứng dụng
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bat-dau-nhanh" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Bắt đầu nhanh
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thuc-hanh-tot-nhat" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Thực hành tốt nhất
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cau-hoi-thuong-gap" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Câu hỏi thường gặp
                </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Các mô-đun (tích hợp)
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-dun" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Mô-đun
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thanh-lap" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Thành lập
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/modules-list" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Danh sách mô-đun
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ung-dung-di-dong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Ứng dụng di động
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tien-dien-tu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      tiền điện tử
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/vach-soc" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Vạch sọc
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ban-do-gis" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Bản đồ &amp; Hệ thống thông tin địa lý
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/su-gia" class="nav-item-title flex-1" data-v-01a2f9b6>
                      sứ giả
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/hoi-thao-qua-video" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Hội nghị truyền hình &amp; hội thảo trên web
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/gui-thu-quang-cao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Gửi thư, quảng cáo
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/e-mail-5" class="nav-item-title flex-1" data-v-01a2f9b6>
                      E-mail
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tin-nhan-sms" class="nav-item-title flex-1" data-v-01a2f9b6>
                      tin nhắn SMS
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tap-tin-phuong-tien" class="nav-item-title flex-1" data-v-01a2f9b6>
                      tập tin phương tiện
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tai-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tài liệu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ngay-gio" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Ngày giờ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/kho-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Lưu trữ dữ liệu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/phien-dich-ngon-ngu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Phiên dịch ngôn ngữ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-dun-dac-biet" class="nav-item-title flex-1" data-v-01a2f9b6>
                      mô-đun đặc biệt
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tap-tin-luu-tru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Lưu trữ tệp
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lap-chi-muc-google" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Lập chỉ mục của Google
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/may-quet-ma-vach" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Máy quét mã vạch
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chuyen-doi-dam-may" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đám mâyChuyển đổi
                    </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              thiết kế dữ liệu
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-hinh-du-lieu-la-gi-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Mô hình dữ liệu là gì
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/loai-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Loại dữ liệu
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/data-models" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Mô hình dữ liệu
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nha-thiet-ke-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhà thiết kế mô hình dữ liệu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-va-sua-doi-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo và sửa đổi mô hình dữ liệu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-va-sua-doi-quan-he" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo và sửa đổi quan hệ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/truong-he-thong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      trường hệ thống
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cac-kieu-quan-he" class="nav-item-title flex-1" data-v-01a2f9b6>
                  các loại quan hệ
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/auto-generation-of-data-models" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Tự động tạo mô hình dữ liệu
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tu-dong-tao-mo-hinh-du-lieu-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tự động tạo mô hình dữ liệu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-hinh-du-lieu-ao-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mô hình dữ liệu ảo
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-hinh-du-lieu-mo-dun-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mô hình dữ liệu mô-đun
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/list-of-generated-models" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Danh sách các mô hình được tạo
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nguoi-dung-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Người dùng mô hình dữ liệu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/phien-nguoi-dung-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Phiên người dùng mô hình dữ liệu
                    </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Logic kinh doanh
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bien-tap-quy-trinh-kinh-doanh" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Trình chỉnh sửa quy trình kinh doanh
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thuc-hanh-tot-nhat-de-tach-bp" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Thực hành tốt nhất để tách HA
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bien-toan-cuc" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Biến toàn cục
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/logic-blocks" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Khối logic
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/neu-khac" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nếu khác
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cho-moi-vong-lap" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đối với mỗi vòng lặp
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/vong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Vòng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ngat-vong-lap" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Phá vỡ vòng lặp
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cong-tac-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Công tắc
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/dat-bien" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đặt biến
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tang-loi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tăng lỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/so-sanh" class="nav-item-title flex-1" data-v-01a2f9b6>
                      So sánh
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/huong-dan-dinh-dang-ngay-gio-thanh-chuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Ngày &amp; Giờ thành chuỗi: Hướng dẫn định dạng
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/math-blocks" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Khối Toán
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nha-khai-thac" class="nav-item-title flex-1" data-v-01a2f9b6>
                      nhà điều hành
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/so-nguyen-ngau-nhien" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Số nguyên ngẫu nhiên/số float
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/vong-len-xuong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Làm tròn lên/xuống
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mod-12" class="nav-item-title flex-1" data-v-01a2f9b6>
                      chế độ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/la-so-chan" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Là Số Chẵn
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/hoat-dong-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Hoạt động mảng
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/string" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Sợi dây
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chuoi-ngau-nhien" class="nav-item-title flex-1" data-v-01a2f9b6>
                      chuỗi ngẫu nhiên
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/noi-chuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Concat Chuỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chieu-dai-chuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Chiều dài chuỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/co-chuoi-con" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Có chuỗi con
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bam" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Băm
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/la-email-hop-le" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Email hợp lệ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thanh-chu-thuong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Viết thường/viết hoa
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chuoi-cat" class="nav-item-title flex-1" data-v-01a2f9b6>
                      cắt chuỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thay-the-chuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Thay thế chuỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lay-char-tai-vi-tri" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhận Char tại vị trí
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tach-chuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      tách chuỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lat-chuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      lát chuỗi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-chuoi-regex" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực Chuỗi (Regex)
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/boolean" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Boolean
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/logic-va" class="nav-item-title flex-1" data-v-01a2f9b6>
                      logic VÀ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/logic-khong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      logic KHÔNG
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/logic-hoac" class="nav-item-title flex-1" data-v-01a2f9b6>
                      logic HOẶC
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/sc-append-array" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Mảng
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/noi-them-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      nối thêm mảng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/them-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      thêm mảng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mang-concat" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mảng concat
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/kich-thuoc-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Kích thước mảng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/trong-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      trong mảng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/yeu-to-ngau-nhien" class="nav-item-title flex-1" data-v-01a2f9b6>
                      yếu tố ngẫu nhiên
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xao-tron-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xáo trộn mảng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/phan-tu-mang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Phần tử mảng
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/date-and-time" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Ngày giờ
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-khoang-thoi-gian-datetimedate" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đặt ngày/giờ/ngày &amp; giờ/khoảng thời gian
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-rong-khoang-thoi-gian-datetimedate" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mở rộng Ngày/Giờ/Ngày &amp; Thời gian/Khoảng thời gian
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/khoang-thoi-gian-cong-tru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Cộng/Trừ Khoảng thời gian
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ngay-gio-hien-tai" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Ngày &amp; Giờ hiện tại
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chenh-lech-ngay-gio" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Chênh lệch ngày &amp; giờ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/su-cham-tre" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Sự chậm trễ
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/file" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Tập tin
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/co-duoc-file" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Có được file
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-tap-tin" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo tệp
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/doc-tep-csv" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đọc tệp CSV
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/doc-tep-xlsx" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đọc tệp XLSX
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/doc-tap-tin-xls" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đọc tệp XLS
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/miscellaneous" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Điều khoản khác
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thong-tin-ung-dung" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Thông tin ứng dụng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ghi-vao-nhat-ky" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Viết để đăng nhập
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhan-tieu-de-yeu-cau" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhận tiêu đề yêu cầu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/dat-tieu-de-phan-hoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đặt tiêu đề phản hồi
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhan-noi-dung-yeu-cau" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhận nội dung yêu cầu
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/model-functions" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Chức năng mô hình
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tim-kiem-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tìm kiếm
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lay-mot-cai" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Lấy một cái
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xoa-bo" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xóa bỏ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-ra" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo ra
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/va" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Vá
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cap-nhat" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Cập nhật
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-rong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mở rộng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lam" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Làm
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/sc-external-api-requests-data-models" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Mô hình dữ liệu yêu cầu API bên ngoài
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-hinh-du-lieu-yeu-cau-api-ben-ngoai" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mô hình dữ liệu yêu cầu API bên ngoài
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-mo-hinh-tham-so-url-apirequestname-trong" class="nav-item-title flex-1 nuxt-link-active" data-v-01a2f9b6>
                      Tạo mô hình tham số URL APIRequestName trong
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-mo-hinh-co-the-apirequestname-trong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo mô hình cơ thể APIRequestName trong
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-mo-hinh-tieu-de-apirequestname-trong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo mô hình tiêu đề APIRequestName trong
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-mo-hinh-truy-van-apirequestname-trong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo mô hình truy vấn APIRequestName trong
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-rong-mo-hinh-tieu-de-apirequestname-ra" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mở rộng mô hình tiêu đề APIRequestName
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-rong-mo-hinh-trang-thai-phan-hoi-apirequestname-ra" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mở rộng mô hình trạng thái phản hồi APIRequestName Out
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-rong-mo-hinh-co-the-apirequestname-ra" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mở rộng APIRequestName Body Model Out
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/virtual-data-model" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Mô hình dữ liệu ảo
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-mo-hinh-du-lieu-ao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo mô hình dữ liệu ảo
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mo-rong-mo-hinh-du-lieu-ao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Mở rộng mô hình dữ liệu ảo
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bps-do-nguoi-dung-tao" class="nav-item-title flex-1" data-v-01a2f9b6>
                  BP do người dùng tạo
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/yeu-cau-api-ben-ngoai-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Yêu cầu API bên ngoài
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bien" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Biến
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nguoi-mau" class="nav-item-title flex-1" data-v-01a2f9b6>
                  người mẫu
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/liet-ke" class="nav-item-title flex-1" data-v-01a2f9b6>
                  liệt kê
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/group-auth" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Xác thực nhóm
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/su-dang-ky" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Sự đăng ký
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/uy-quyen" class="nav-item-title flex-1" data-v-01a2f9b6>
                      ủy quyền
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/dang-xuat" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đăng xuất
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/doi-mat-khau" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đổi mật khẩu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/khoi-phuc-mat-khau" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Khôi phục mật khẩu
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/them-nguoi-dung-vao-nhom" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Thêm người dùng vào nhóm
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xoa-nguoi-dung-khoi-nhom" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xóa người dùng khỏi nhóm
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhan-nguoi-dung-hien-tai" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhận người dùng hiện tại
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-ma-thong-bao-xac-thuc" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo mã thông báo xác thực
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/mat-khau-bam" class="nav-item-title flex-1" data-v-01a2f9b6>
                      mật khẩu băm
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tham-do-mat-khau" class="nav-item-title flex-1" data-v-01a2f9b6>
                      mật khẩu thăm dò
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-ogrnip-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực OGRNIP RU
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-snil-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực SNILS RU
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-nha-tro-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực INN RU
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-kpp-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực KPP RU
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-bik-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực BIK RU
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-iin-kz" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực IIN KZ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-so-the-ngan-hang-luhn" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực số thẻ ngân hàng (Luhn)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-ks-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực KS RU
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-rs-ru" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Xác thực RS RU
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/yeu-cau-api-ben-ngoai" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Yêu cầu API bên ngoài
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cau-hoi-thuong-gap-6" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Câu hỏi thường gặp
                </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Điểm cuối (API)
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cau-hinh-diem-cuoi" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Cấu hình điểm cuối
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xac-thuc-ma-thong-bao-phan-mem-trung-gian" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Phần mềm trung gian: Xác thực mã thông báo
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/quyen-truy-cap" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Truy cập &amp; Quyền
                </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              ứng dụng web
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nha-thiet-ke-ung-dung-web" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Nhà thiết kế ứng dụng web
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lam-viec-voi-cac-thanh-phan" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Làm việc với các thành phần
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/hinh-thuc-dang-ky-va-dang-nhap" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Biểu mẫu đăng ký và đăng nhập
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/quy-trinh-lam-viec-trong-cac-ung-dung-web" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Quy trình làm việc trong các ứng dụng web
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/web-designer-components" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Thành phần thiết kế web
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thung-dung-hang" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Thùng đựng hàng
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cai-nut" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Cái nút
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tha-xuong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      thả xuống
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/ban" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Bàn
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/luot-xem" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Lượt xem
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tab-1" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Các tab
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cong-tac" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Công tắc
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhan-mac" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhãn mác
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/hinh-anh" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Hình ảnh
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/video-10" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Video
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/do-thi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đồ thị
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/hinh-thuc" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Hình thức
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chuoi-dau-vao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Chuỗi đầu vào)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhap-ky-tu" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhập ký tự)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/so-nguyen-dau-vao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đầu vào (số nguyên)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/phao-dau-vao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đầu vào (thả nổi)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/email-dau-vao" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đầu vào (email)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhap-mat-ma" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Nhập mật mã)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/dien-thoai-nhap-khau" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Điện thoại nhập khẩu)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bien-tap-soan-thao-van-ban" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Biên tập soạn thảo văn bản
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/khoang-thoi-gian" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Khoảng thời gian
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bang-chon-ngay" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Bảng chọn ngày
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bo-chon-thoi-gian" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Bộ chọn thời gian
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bo-chon-ngay-gio" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Bộ chọn ngày giờ
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lua-chon" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Lựa chọn
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chon-liet-ke" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Chọn (enum)
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/chon-lai" class="nav-item-title flex-1" data-v-01a2f9b6>
                      chọn lại
                    </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Ứng dụng di động
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nha-thiet-ke-ung-dung-di-dong" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Nhà thiết kế ứng dụng di động
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-mot-ung-dung-di-dong" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Tạo ứng dụng dành cho thiết bị di động
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thiet-ke-giao-dien-di-dong" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Giao diện thiết kế di động
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lam-viec-voi-man-hinh" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Làm việc với Màn hình
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/lam-viec-voi-widget" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Làm việc với Widget
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xuat-ban-mot-ung-dung-di-dong" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Xuất bản ứng dụng dành cho thiết bị di động
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thu-nghiem-trong-ung-dung-danh-cho-nha-phat-trien-appmasterio" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Thử nghiệm trong Ứng dụng dành cho nhà phát triển AppMaster.io
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/publishing-to-google-play" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Xuất bản lên Google Play
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-tai-khoan-nha-phat-trien-google" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo tài khoản nhà phát triển Google
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-du-an-firebase" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo dự án Firebase
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/dang-ky-tep-cau-hinh-tai-xuong-ung-dung-android" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Đăng ký ứng dụng Android và tải xuống tệp cấu hình
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-khoa-rieng-tai-xuong" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo và tải xuống khóa cá nhân
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-tap-tin-apkaab" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo tệp APK/AAB
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tai-len-ung-dung-de-thu-nghiem" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tải lên ứng dụng để thử nghiệm
                    </a></div></div></div></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/publishing-to-app-store" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Xuất bản lên App Store
                </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-01a2f9b6><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-01a2f9b6><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-01a2f9b6></use></svg></i></div> <div class="nav-item-child pl-4 hidden" data-v-01a2f9b6><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-tai-khoan-nha-phat-trien-apple" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo tài khoản nhà phát triển Apple
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-id-goi-apple" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo ID gói Apple
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-ung-dung-trong-cua-hang-ung-dung-ket-noi" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo ứng dụng trong App Store Connect
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/tao-ban-dung-tai-len-testflight" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Tạo Bản dựng &amp; Tải lên TestFlight
                    </a></div></div><div class="child-item" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/gui-ung-dung-den-cua-hang-ung-dung" class="nav-item-title flex-1" data-v-01a2f9b6>
                      Gửi ứng dụng lên App Store
                    </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              triển khai
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/cau-hinh-trien-khai" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Cấu hình triển khai
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/dich-vu-dam-may-appmasterio" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Dịch vụ đám mây AppMaster.io
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/xuat-du-lieu" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Xuất dữ liệu
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/khuc-go" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Nhật ký
                </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-01a2f9b6><div class="nav-element flex items-center gap-2" data-v-01a2f9b6><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-01a2f9b6>
              Làm thế nào để
            </span></div> <div class="nav-item-childs" data-v-01a2f9b6><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/nhap-tep-csvexcel" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Nhập tệp CSV/Excel
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/thiet-lap-nut" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Cài đặt nút
                </a> <!----></div> <!----></div><div class="nav-item-child" data-v-01a2f9b6><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-01a2f9b6><a href="/docs/vi/bo-tri-giao-dien-nguoi-dung" class="nav-item-title flex-1" data-v-01a2f9b6>
                  Bố cục giao diện người dùng
                </a> <!----></div> <!----></div></div></div></div></div></div> <div class="mobile-back flex-1 bg-dark-500" data-v-01a2f9b6></div></div> <!----></header> <main class="main lg:flex"><aside class="aside w-[264px] bg-blueGray-100 pl-5 pr-1 py-6 flex-shrink-0 hidden lg:block fixed left-0 lg:top-[68px] xl:top-[70px] h-full overflow-auto custom-scroll" data-v-6fbe9787><div itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" class="nav-items pb-20" data-v-6fbe9787><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Bắt đầu
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/getting-started/appmaster-io-la-gi" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              AppMaster.io là gì
            </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Bắt đầu
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/getting-started-en/kien-truc-ung-dung" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Kiến trúc ứng dụng
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/getting-started-en/bat-dau-nhanh" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Bắt đầu nhanh
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/getting-started-en/thuc-hanh-tot-nhat" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Thực hành tốt nhất
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/getting-started-en/cau-hoi-thuong-gap" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Câu hỏi thường gặp
            </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Các mô-đun (tích hợp)
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/mo-dun" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Mô-đun
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/thanh-lap" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Thành lập
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/modules-list" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Danh sách mô-đun
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/ung-dung-di-dong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Ứng dụng di động
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/tien-dien-tu" class="nav-item-title flex-1" data-v-6fbe9787>
                  tiền điện tử
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/xac-thuc" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/vach-soc" class="nav-item-title flex-1" data-v-6fbe9787>
                  Vạch sọc
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/ban-do-gis" class="nav-item-title flex-1" data-v-6fbe9787>
                  Bản đồ &amp; Hệ thống thông tin địa lý
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/su-gia" class="nav-item-title flex-1" data-v-6fbe9787>
                  sứ giả
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/hoi-thao-qua-video" class="nav-item-title flex-1" data-v-6fbe9787>
                  Hội nghị truyền hình &amp; hội thảo trên web
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/gui-thu-quang-cao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Gửi thư, quảng cáo
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/e-mail-5" class="nav-item-title flex-1" data-v-6fbe9787>
                  E-mail
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/tin-nhan-sms" class="nav-item-title flex-1" data-v-6fbe9787>
                  tin nhắn SMS
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/tap-tin-phuong-tien" class="nav-item-title flex-1" data-v-6fbe9787>
                  tập tin phương tiện
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/tai-lieu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tài liệu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/ngay-gio" class="nav-item-title flex-1" data-v-6fbe9787>
                  Ngày giờ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/kho-du-lieu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Lưu trữ dữ liệu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/phien-dich-ngon-ngu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Phiên dịch ngôn ngữ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/mo-dun-dac-biet" class="nav-item-title flex-1" data-v-6fbe9787>
                  mô-đun đặc biệt
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/tap-tin-luu-tru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Lưu trữ tệp
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/lap-chi-muc-google" class="nav-item-title flex-1" data-v-6fbe9787>
                  Lập chỉ mục của Google
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/may-quet-ma-vach" class="nav-item-title flex-1" data-v-6fbe9787>
                  Máy quét mã vạch
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/modules-integrations/chuyen-doi-dam-may" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đám mâyChuyển đổi
                </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          thiết kế dữ liệu
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/mo-hinh-du-lieu-la-gi-1" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Mô hình dữ liệu là gì
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/loai-du-lieu" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Loại dữ liệu
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/data-models" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Mô hình dữ liệu
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/nha-thiet-ke-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhà thiết kế mô hình dữ liệu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/tao-va-sua-doi-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo và sửa đổi mô hình dữ liệu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/tao-va-sua-doi-quan-he" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo và sửa đổi quan hệ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/truong-he-thong" class="nav-item-title flex-1" data-v-6fbe9787>
                  trường hệ thống
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/cac-kieu-quan-he" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              các loại quan hệ
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/auto-generation-of-data-models" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Tự động tạo mô hình dữ liệu
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/tu-dong-tao-mo-hinh-du-lieu-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tự động tạo mô hình dữ liệu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/mo-hinh-du-lieu-ao-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mô hình dữ liệu ảo
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/mo-hinh-du-lieu-mo-dun-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mô hình dữ liệu mô-đun
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/list-of-generated-models" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Danh sách các mô hình được tạo
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/nguoi-dung-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Người dùng mô hình dữ liệu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/data-design/phien-nguoi-dung-mo-hinh-du-lieu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Phiên người dùng mô hình dữ liệu
                </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Logic kinh doanh
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/bien-tap-quy-trinh-kinh-doanh" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Trình chỉnh sửa quy trình kinh doanh
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/thuc-hanh-tot-nhat-de-tach-bp" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Thực hành tốt nhất để tách HA
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/bien-toan-cuc" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Biến toàn cục
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/logic-blocks" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Khối logic
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/neu-khac" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nếu khác
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/cho-moi-vong-lap" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đối với mỗi vòng lặp
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/vong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Vòng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/ngat-vong-lap" class="nav-item-title flex-1" data-v-6fbe9787>
                  Phá vỡ vòng lặp
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/cong-tac-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Công tắc
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/dat-bien" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đặt biến
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tang-loi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tăng lỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/so-sanh" class="nav-item-title flex-1" data-v-6fbe9787>
                  So sánh
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/huong-dan-dinh-dang-ngay-gio-thanh-chuoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Ngày &amp; Giờ thành chuỗi: Hướng dẫn định dạng
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/math-blocks" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Khối Toán
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/nha-khai-thac" class="nav-item-title flex-1" data-v-6fbe9787>
                  nhà điều hành
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/so-nguyen-ngau-nhien" class="nav-item-title flex-1" data-v-6fbe9787>
                  Số nguyên ngẫu nhiên/số float
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/vong-len-xuong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Làm tròn lên/xuống
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mod-12" class="nav-item-title flex-1" data-v-6fbe9787>
                  chế độ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/la-so-chan" class="nav-item-title flex-1" data-v-6fbe9787>
                  Là Số Chẵn
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/hoat-dong-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  Hoạt động mảng
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/string" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Sợi dây
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/chuoi-ngau-nhien" class="nav-item-title flex-1" data-v-6fbe9787>
                  chuỗi ngẫu nhiên
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/noi-chuoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Concat Chuỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/chieu-dai-chuoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Chiều dài chuỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/co-chuoi-con" class="nav-item-title flex-1" data-v-6fbe9787>
                  Có chuỗi con
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/bam" class="nav-item-title flex-1" data-v-6fbe9787>
                  Băm
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/la-email-hop-le" class="nav-item-title flex-1" data-v-6fbe9787>
                  Email hợp lệ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/thanh-chu-thuong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Viết thường/viết hoa
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/chuoi-cat" class="nav-item-title flex-1" data-v-6fbe9787>
                  cắt chuỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/thay-the-chuoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Thay thế chuỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/lay-char-tai-vi-tri" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhận Char tại vị trí
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tach-chuoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  tách chuỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/lat-chuoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  lát chuỗi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-chuoi-regex" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực Chuỗi (Regex)
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/boolean" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Boolean
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/logic-va" class="nav-item-title flex-1" data-v-6fbe9787>
                  logic VÀ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/logic-khong" class="nav-item-title flex-1" data-v-6fbe9787>
                  logic KHÔNG
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/logic-hoac" class="nav-item-title flex-1" data-v-6fbe9787>
                  logic HOẶC
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/sc-append-array" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Mảng
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/noi-them-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  nối thêm mảng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/them-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  thêm mảng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mang-concat" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mảng concat
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/kich-thuoc-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  Kích thước mảng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/trong-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  trong mảng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/yeu-to-ngau-nhien" class="nav-item-title flex-1" data-v-6fbe9787>
                  yếu tố ngẫu nhiên
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xao-tron-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xáo trộn mảng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/phan-tu-mang" class="nav-item-title flex-1" data-v-6fbe9787>
                  Phần tử mảng
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/date-and-time" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Ngày giờ
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-khoang-thoi-gian-datetimedate" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đặt ngày/giờ/ngày &amp; giờ/khoảng thời gian
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-rong-khoang-thoi-gian-datetimedate" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mở rộng Ngày/Giờ/Ngày &amp; Thời gian/Khoảng thời gian
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/khoang-thoi-gian-cong-tru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Cộng/Trừ Khoảng thời gian
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/ngay-gio-hien-tai" class="nav-item-title flex-1" data-v-6fbe9787>
                  Ngày &amp; Giờ hiện tại
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/chenh-lech-ngay-gio" class="nav-item-title flex-1" data-v-6fbe9787>
                  Chênh lệch ngày &amp; giờ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/su-cham-tre" class="nav-item-title flex-1" data-v-6fbe9787>
                  Sự chậm trễ
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/file" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Tập tin
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/co-duoc-file" class="nav-item-title flex-1" data-v-6fbe9787>
                  Có được file
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-tap-tin" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo tệp
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/doc-tep-csv" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đọc tệp CSV
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/doc-tep-xlsx" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đọc tệp XLSX
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/doc-tap-tin-xls" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đọc tệp XLS
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/miscellaneous" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Điều khoản khác
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/thong-tin-ung-dung" class="nav-item-title flex-1" data-v-6fbe9787>
                  Thông tin ứng dụng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/ghi-vao-nhat-ky" class="nav-item-title flex-1" data-v-6fbe9787>
                  Viết để đăng nhập
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/nhan-tieu-de-yeu-cau" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhận tiêu đề yêu cầu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/dat-tieu-de-phan-hoi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đặt tiêu đề phản hồi
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/nhan-noi-dung-yeu-cau" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhận nội dung yêu cầu
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/model-functions" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Chức năng mô hình
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tim-kiem-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tìm kiếm
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/lay-mot-cai" class="nav-item-title flex-1" data-v-6fbe9787>
                  Lấy một cái
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xoa-bo" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xóa bỏ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-ra" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo ra
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/va" class="nav-item-title flex-1" data-v-6fbe9787>
                  Vá
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/cap-nhat" class="nav-item-title flex-1" data-v-6fbe9787>
                  Cập nhật
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-rong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mở rộng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/lam" class="nav-item-title flex-1" data-v-6fbe9787>
                  Làm
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/sc-external-api-requests-data-models" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Mô hình dữ liệu yêu cầu API bên ngoài
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-hinh-du-lieu-yeu-cau-api-ben-ngoai" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mô hình dữ liệu yêu cầu API bên ngoài
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-mo-hinh-tham-so-url-apirequestname-trong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo mô hình tham số URL APIRequestName trong
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-mo-hinh-co-the-apirequestname-trong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo mô hình cơ thể APIRequestName trong
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-mo-hinh-tieu-de-apirequestname-trong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo mô hình tiêu đề APIRequestName trong
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-mo-hinh-truy-van-apirequestname-trong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo mô hình truy vấn APIRequestName trong
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-rong-mo-hinh-tieu-de-apirequestname-ra" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mở rộng mô hình tiêu đề APIRequestName
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-rong-mo-hinh-trang-thai-phan-hoi-apirequestname-ra" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mở rộng mô hình trạng thái phản hồi APIRequestName Out
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-rong-mo-hinh-co-the-apirequestname-ra" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mở rộng APIRequestName Body Model Out
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/virtual-data-model" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Mô hình dữ liệu ảo
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-mo-hinh-du-lieu-ao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo mô hình dữ liệu ảo
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mo-rong-mo-hinh-du-lieu-ao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Mở rộng mô hình dữ liệu ảo
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/bps-do-nguoi-dung-tao" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              BP do người dùng tạo
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/yeu-cau-api-ben-ngoai-1" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Yêu cầu API bên ngoài
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/bien" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Biến
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/nguoi-mau" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              người mẫu
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/liet-ke" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              liệt kê
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/group-auth" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Xác thực nhóm
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/su-dang-ky" class="nav-item-title flex-1" data-v-6fbe9787>
                  Sự đăng ký
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/uy-quyen" class="nav-item-title flex-1" data-v-6fbe9787>
                  ủy quyền
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/dang-xuat" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đăng xuất
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/doi-mat-khau" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đổi mật khẩu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/khoi-phuc-mat-khau" class="nav-item-title flex-1" data-v-6fbe9787>
                  Khôi phục mật khẩu
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/them-nguoi-dung-vao-nhom" class="nav-item-title flex-1" data-v-6fbe9787>
                  Thêm người dùng vào nhóm
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xoa-nguoi-dung-khoi-nhom" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xóa người dùng khỏi nhóm
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/nhan-nguoi-dung-hien-tai" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhận người dùng hiện tại
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tao-ma-thong-bao-xac-thuc" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo mã thông báo xác thực
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/mat-khau-bam" class="nav-item-title flex-1" data-v-6fbe9787>
                  mật khẩu băm
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/tham-do-mat-khau" class="nav-item-title flex-1" data-v-6fbe9787>
                  mật khẩu thăm dò
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-ogrnip-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực OGRNIP RU
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-snil-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực SNILS RU
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-nha-tro-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực INN RU
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-kpp-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực KPP RU
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-bik-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực BIK RU
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-iin-kz" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực IIN KZ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-so-the-ngan-hang-luhn" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực số thẻ ngân hàng (Luhn)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-ks-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực KS RU
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/xac-thuc-rs-ru" class="nav-item-title flex-1" data-v-6fbe9787>
                  Xác thực RS RU
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/yeu-cau-api-ben-ngoai" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Yêu cầu API bên ngoài
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/business-logic/cau-hoi-thuong-gap-6" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Câu hỏi thường gặp
            </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Điểm cuối (API)
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/endpoints-api/cau-hinh-diem-cuoi" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Cấu hình điểm cuối
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/endpoints-api/xac-thuc-ma-thong-bao-phan-mem-trung-gian" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Phần mềm trung gian: Xác thực mã thông báo
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/endpoints-api/quyen-truy-cap" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Truy cập &amp; Quyền
            </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          ứng dụng web
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/nha-thiet-ke-ung-dung-web" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Nhà thiết kế ứng dụng web
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/lam-viec-voi-cac-thanh-phan" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Làm việc với các thành phần
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/hinh-thuc-dang-ky-va-dang-nhap" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Biểu mẫu đăng ký và đăng nhập
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/quy-trinh-lam-viec-trong-cac-ung-dung-web" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Quy trình làm việc trong các ứng dụng web
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/web-designer-components" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Thành phần thiết kế web
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/thung-dung-hang" class="nav-item-title flex-1" data-v-6fbe9787>
                  Thùng đựng hàng
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/cai-nut" class="nav-item-title flex-1" data-v-6fbe9787>
                  Cái nút
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/tha-xuong" class="nav-item-title flex-1" data-v-6fbe9787>
                  thả xuống
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/ban" class="nav-item-title flex-1" data-v-6fbe9787>
                  Bàn
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/luot-xem" class="nav-item-title flex-1" data-v-6fbe9787>
                  Lượt xem
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/tab-1" class="nav-item-title flex-1" data-v-6fbe9787>
                  Các tab
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/cong-tac" class="nav-item-title flex-1" data-v-6fbe9787>
                  Công tắc
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/nhan-mac" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhãn mác
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/hinh-anh" class="nav-item-title flex-1" data-v-6fbe9787>
                  Hình ảnh
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/video-10" class="nav-item-title flex-1" data-v-6fbe9787>
                  Video
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/do-thi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đồ thị
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/hinh-thuc" class="nav-item-title flex-1" data-v-6fbe9787>
                  Hình thức
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/chuoi-dau-vao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Chuỗi đầu vào)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/nhap-ky-tu" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhập ký tự)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/so-nguyen-dau-vao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đầu vào (số nguyên)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/phao-dau-vao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đầu vào (thả nổi)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/email-dau-vao" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đầu vào (email)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/nhap-mat-ma" class="nav-item-title flex-1" data-v-6fbe9787>
                  Nhập mật mã)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/dien-thoai-nhap-khau" class="nav-item-title flex-1" data-v-6fbe9787>
                  Điện thoại nhập khẩu)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/bien-tap-soan-thao-van-ban" class="nav-item-title flex-1" data-v-6fbe9787>
                  Biên tập soạn thảo văn bản
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/khoang-thoi-gian" class="nav-item-title flex-1" data-v-6fbe9787>
                  Khoảng thời gian
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/bang-chon-ngay" class="nav-item-title flex-1" data-v-6fbe9787>
                  Bảng chọn ngày
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/bo-chon-thoi-gian" class="nav-item-title flex-1" data-v-6fbe9787>
                  Bộ chọn thời gian
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/bo-chon-ngay-gio" class="nav-item-title flex-1" data-v-6fbe9787>
                  Bộ chọn ngày giờ
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/lua-chon" class="nav-item-title flex-1" data-v-6fbe9787>
                  Lựa chọn
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/chon-liet-ke" class="nav-item-title flex-1" data-v-6fbe9787>
                  Chọn (enum)
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/web-apps/chon-lai" class="nav-item-title flex-1" data-v-6fbe9787>
                  chọn lại
                </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Ứng dụng di động
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/nha-thiet-ke-ung-dung-di-dong" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Nhà thiết kế ứng dụng di động
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-mot-ung-dung-di-dong" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Tạo ứng dụng dành cho thiết bị di động
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/thiet-ke-giao-dien-di-dong" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Giao diện thiết kế di động
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/lam-viec-voi-man-hinh" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Làm việc với Màn hình
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/lam-viec-voi-widget" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Làm việc với Widget
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/xuat-ban-mot-ung-dung-di-dong" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Xuất bản ứng dụng dành cho thiết bị di động
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/thu-nghiem-trong-ung-dung-danh-cho-nha-phat-trien-appmasterio" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Thử nghiệm trong Ứng dụng dành cho nhà phát triển AppMaster.io
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/publishing-to-google-play" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Xuất bản lên Google Play
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-tai-khoan-nha-phat-trien-google" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo tài khoản nhà phát triển Google
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-du-an-firebase" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo dự án Firebase
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/dang-ky-tep-cau-hinh-tai-xuong-ung-dung-android" class="nav-item-title flex-1" data-v-6fbe9787>
                  Đăng ký ứng dụng Android và tải xuống tệp cấu hình
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-khoa-rieng-tai-xuong" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo và tải xuống khóa cá nhân
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-tap-tin-apkaab" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo tệp APK/AAB
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tai-len-ung-dung-de-thu-nghiem" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tải lên ứng dụng để thử nghiệm
                </a></div></div></div></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/publishing-to-app-store" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Xuất bản lên App Store
            </a> <i class="nav-item__ico select-arrow w-4 h-4" data-v-6fbe9787><svg class="svg w-3.7 h-3.7 text-dark-200" data-v-6fbe9787><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-6fbe9787></use></svg></i></div> <div class="nav-item-child lg:pl-4 hidden" data-v-6fbe9787><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-tai-khoan-nha-phat-trien-apple" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo tài khoản nhà phát triển Apple
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-id-goi-apple" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo ID gói Apple
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-ung-dung-trong-cua-hang-ung-dung-ket-noi" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo ứng dụng trong App Store Connect
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/tao-ban-dung-tai-len-testflight" class="nav-item-title flex-1" data-v-6fbe9787>
                  Tạo Bản dựng &amp; Tải lên TestFlight
                </a></div></div><div class="child-item" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/mobile-apps/gui-ung-dung-den-cua-hang-ung-dung" class="nav-item-title flex-1" data-v-6fbe9787>
                  Gửi ứng dụng lên App Store
                </a></div></div></div></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          triển khai
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/deployment/cau-hinh-trien-khai" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Cấu hình triển khai
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/deployment/dich-vu-dam-may-appmasterio" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Dịch vụ đám mây AppMaster.io
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/deployment/xuat-du-lieu" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Xuất dữ liệu
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/deployment/khuc-go" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Nhật ký
            </a> <!----></div> <!----></div></div></div><div class="nav-item px-2" data-v-6fbe9787><div class="nav-element flex items-center gap-2" data-v-6fbe9787><span class="nav-item__link flex-1 text-sm leading-2.2 font-bold text-dark-500 py-2 2xl:text-m 2xl:leading-5" data-v-6fbe9787>
          Làm thế nào để
        </span></div> <div class="nav-item-childs" data-v-6fbe9787><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/how-to/nhap-tep-csvexcel" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Nhập tệp CSV/Excel
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/how-to/thiet-lap-nut" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Cài đặt nút
            </a> <!----></div> <!----></div><div class="nav-item-child" data-v-6fbe9787><div class="pl-4 py-2 flex items-center gap-2 text-dark-400 text-micro leading-5 font-medium 2xl:text-sm" data-v-6fbe9787><a href="/docs/vi/how-to/bo-tri-giao-dien-nguoi-dung" itemprop="url" class="nav-item-title flex-1" data-v-6fbe9787>
              Bố cục giao diện người dùng
            </a> <!----></div> <!----></div></div></div></div></aside> <div class="lg:flex-1 lg:xl-[264px] xl:pl-0 content-wrapp"><div><div class="lg:flex-1 lg:pl-[264px] xl:pl-0 content-wrapp"><div class="content pt-6 sm:pt-8 lg:pt-10"><div class="container mx-auto sm:px-8 article-content lg:px-0 flex flex-col"><div class="content-header flex items-start justify-between gap-1.5 mb-2"><h1 class="text-[26px] leading-[34px] font-bold text-dark-500 sm:text-[30px] sm:leading-10">
        Tạo mô hình tham số URL APIRequestName trong
      </h1> <div data-v-6bb825aa><textarea readonly="readonly" class="hidden" data-v-6bb825aa></textarea> <div class="relative inline-flex items-center tooltip-wrapper" data-v-6bb825aa><span class="inline-table items-center absolute tooltip bg-dark-500 rounded-lg py-1.5 px-2 text-xs leading-5 text-white font-medium whitespace-nowrap" data-v-6bb825aa><span data-v-6bb825aa>Nhấn vào đây để sao chép</span></span> <button class="content-header-btn w-[34px] h-[34px] border border-solid border-blueGray-200 rounded-md inline-flex items-center justify-center flex-shrink-0 sm:w-[40px] sm:h-[40px]" data-v-6bb825aa><svg class="svg w-[22px] h-[22px] text-dark-400" data-v-6bb825aa><use xlink:href="/images/icons.svg#chain-ico" data-v-6bb825aa></use></svg></button></div></div></div> <div class="content-desc text-micro leading-2.2 text-dark-300 font-normal sm:text-base sm:leading-2.6"><p>Trả về một đối tượng mô hình Tham số URL mới cho một yêu cầu API cụ thể từ các trường đã cho.</p></div> <hr class="h-[1px] w-full bg-blueGray-200 my-4 sm:my-8"> <div class="article-content text-micro leading-2.2 sm:text-sm sm:leading-6 md:text-sm md:leading-6 lg:text-m lg:leading-6 xl:text-m 2xl:text-m prose sm:prose-sm md:prose-md lg:prose-lg xl:prose-xl mb-10 sm:mb-12 max-w-none flex-1"><div class="text-micro font-normal sm:text-sm sm:leading-6 sm:font-normal lg:font-medium xl:text-m"><h2 id="ket-noi-dong-chay">Kết nối dòng chảy</h2><ul><li><span class="notranslate">[Input] In</span> - bắt đầu thực thi khối.</li><li> <span class="notranslate">[Output] Out</span> - kích hoạt khi khối thực hiện xong.</li></ul><h2 id="ket-noi-du-lieu"> Kết nối dữ liệu</h2><ul><li><span class="notranslate">[Input] Fields (multiple, any)</span> - các trường của mô hình Thông số URL (được xác định trong phần tương ứng của nó trong Yêu cầu API bên ngoài).</li><li> <span class="notranslate">[Output] Model (model</span> ) - mô hình kết quả.</li></ul></div></div> <div class="page-nav flex flex-col gap-2 mb-6 sm:flex-row sm:gap-4 sm:mb-8" data-v-72d22e64><a href="/docs/vi/mo-hinh-du-lieu-yeu-cau-api-ben-ngoai" class="page-nav__link inline-flex gap-2 items-center text-micro font-semibold border border-solid border-blueGray-200 rounded-lg text-dark-500 justify-start px-4 py-3 sm:flex-1 sm:text-sm sm:leading-2.6" data-v-72d22e64><i class="page-nav__ico page-nav__ico_left w-7 h-7 inline-flex items-center justify-center text-blueGray-500" data-v-72d22e64><svg class="svg" data-v-72d22e64><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-72d22e64></use></svg></i> <span class="page-nav__title" data-v-72d22e64>Mô hình dữ liệu yêu cầu API bên ngoài</span></a> <a href="/docs/vi/tao-mo-hinh-co-the-apirequestname-trong" class="page-nav__link inline-flex gap-2 items-center text-micro font-semibold border border-solid border-blueGray-200 rounded-lg text-dark-500 justify-end px-4 py-3 sm:flex-1 sm:text-sm sm:leading-2.6" data-v-72d22e64><span class="page-nav__title" data-v-72d22e64>Tạo mô hình cơ thể APIRequestName trong</span> <i class="page-nav__ico page-nav__ico_right w-7 h-7 inline-flex items-center justify-center text-blueGray-500" data-v-72d22e64><svg class="svg" data-v-72d22e64><use xlink:href="/images/icons.svg#arrow-down-ico" data-v-72d22e64></use></svg></i></a></div></div></div> <footer class="footer"><div class="container article-content mx-auto sm:px-8 lg:px-0"><div class="footer-nav pb-12 sm:flex sm:justify-between sm:gap-4 sm:items-center sm:border-t sm:border-solid sm:border-blueGray-200 sm:pt-10 sm:pb-16"><div class="soc-w mb-8 sm:mb-0" data-v-da5ed684><hr class="bg-blueGray-200 h-[1px] w-full rounded-sm hidden" data-v-da5ed684> <div class="soc aside-soc flex items-center justify-center gap-x-2 xl:justify-start lg:gap-x-1" data-v-da5ed684><button aria-label="facebook" class="w-[34px] h-[34px] border border-solid border-dark-100 rounded-md inline-flex items-center justify-center sm:w-[38px] sm:h-[38px] hover:bg-primary-500 text-dark-400 hover:text-white share-network-facebook" data-v-da5ed684><svg class="svg w-3.7 h-3.7" data-v-da5ed684><use xlink:href="/images/icons.svg#facebook" data-v-da5ed684></use></svg></button><button aria-label="twitter" class="w-[34px] h-[34px] border border-solid border-dark-100 rounded-md inline-flex items-center justify-center sm:w-[38px] sm:h-[38px] hover:bg-primary-500 text-dark-400 hover:text-white share-network-twitter" data-v-da5ed684><svg class="svg w-3.7 h-3.7" data-v-da5ed684><use xlink:href="/images/icons.svg#twitter" data-v-da5ed684></use></svg></button><button aria-label="LinkedIn" class="w-[34px] h-[34px] border border-solid border-dark-100 rounded-md inline-flex items-center justify-center sm:w-[38px] sm:h-[38px] hover:bg-primary-500 text-dark-400 hover:text-white share-network-linkedin" data-v-da5ed684><svg class="svg w-3.7 h-3.7" data-v-da5ed684><use xlink:href="/images/icons.svg#in" data-v-da5ed684></use></svg></button></div></div></div></div></footer></div> <aside class="on-page w-[264px] flex-shrink-0 px-5 py-6 border-l border-solid border-blueGray-200 hidden xl:block fixed right-0 top-[70px] h-full overflow-auto custom-scroll" data-v-a4c7efd0><div class="pb-20 on-page-content" data-v-a4c7efd0><span class="on-page__title block text-m leading-5 font-semibold text-dark-500 mb-2 2xl:text-m 2xl:leading-5" data-v-a4c7efd0>
      Trên trang này
    </span> <nav class="on-page-nav" data-v-a4c7efd0><div class="on-page-item" data-v-a4c7efd0><a href="vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong#ket-noi-dong-chay" class="text-sm text-dark-400 leading-5 block py-1.5 font-medium hover:text-primary-500 2xl:text-sm 2xl:leading-5" data-v-a4c7efd0>
          Kết nối dòng chảy
        </a> <!----></div><div class="on-page-item" data-v-a4c7efd0><a href="vi/tao-mo-hinh-tham-so-url-apirequestname-trong/tao-mo-hinh-tham-so-url-apirequestname-trong#ket-noi-du-lieu" class="text-sm text-dark-400 leading-5 block py-1.5 font-medium hover:text-primary-500 2xl:text-sm 2xl:leading-5" data-v-a4c7efd0>
           Kết nối dữ liệu
        </a> <!----></div></nav></div></aside></div></div></main></div></div></div><script>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</script><script src="/docs/_nuxt/7e01a59.js" defer></script><script src="/docs/_nuxt/0636c76.js" defer></script><script src="/docs/_nuxt/5c018ca.js" defer></script><script src="/docs/_nuxt/f389214.js" defer></script><script src="/docs/_nuxt/cb7eb6e.js" defer></script><script src="/docs/_nuxt/b52fb0f.js" defer></script><script src="/docs/_nuxt/fe1d34d.js" defer></script><script src="/docs/_nuxt/0349aee.js" defer></script><script src="/docs/_nuxt/71dc126.js" defer></script><script src="/docs/_nuxt/306525a.js" defer></script><script src="/docs/_nuxt/3458d2d.js" defer></script><script src="/docs/_nuxt/385e0b7.js" defer></script><script src="/docs/_nuxt/705d46d.js" defer></script><script src="/docs/_nuxt/3953717.js" defer></script>
  </body>
</html>
